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Banner 7 Interface Changes 
Banner 7, although not changing much in function, has a new look and feel. These 
changes are listed below, then discussed in more detail in the following pages. 

Main Menu Changes 

• The Go field changed to Go To; you can now use   and   to scroll 
through recently used forms. 

• You can now press  to navigate to a different form;  and  navigation 
also works in this field. 

• All toolbar icons are visible in the Main Menu. 
• Quickflows now launch directly from the Go To field. 
• New Help Center link. 
• My Links section. 

Enhanced User Interface 
• Tabbed forms make navigating from block to block easier 
• New screen resolution to make more data visible 
• Icons changed, moved for better grouping, or removed 
• Made disabled text easier to read 
• Added pop-up options list with right mouse click 
• Added smart toolbar that does not re-draw each time a form is opened 
• Enabled user-defined window colors 
• Ability to add Personal Links to the Banner Main Menu 

• Replaced blue item (field) labels with Search icon ( ) 
• Changed the font to Verdana 
• Equal left and right margins 
• Added calendar icon to data entry date fields 

New Help System for Banner 7 
Banner 7 has improved the Help system. Please refer to New Banner Online Help for 
information about the new help system. 
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Main Menu Changes 

Go Field Changed To Go To 
The Go field has been renamed Go To. In addition, when your cursor is in the Go To 

field, you can use  and  to scroll through recently used forms. 

 Added As Alternative To Direct Access 

Navigation between forms is improved. You can now press  to navigate to a 
different form without leaving the form you are in.  Direct Access is still available from 

the File menu.  The  and  navigation also works in this field. 

All Icons Now Visible In The Main Menu 
The entire toolbar is now accessible from the Main Menu. 

Quickflow Access 
You can now launch a QuickFlow directly from the Go To field, rather than first being 
directed to the QuickFlow Form (GUAQFLW). 

Help Center Link 
The Help Center link accesses the SCT Banner Help Center. Refer to New Banner 
Online Help for information about the new help system. 

My Links 
• The Change Banner Password link goes to the Oracle Password Change Form 

(GUAPSWD), where you can change your password. 
• The Check Banner Message link takes you to the Banner Message Form 

(GUAMESG), where you can view your messages. A green check mark appears 
next to the link when you initially log in and have pending messages, or whenever 
a new message arrives. The pop-up alert for new messages is no longer displayed. 

• Personal links enable you to create up to six links to favorite URLs or often-used 
Banner objects.  Refer to the Enhanced User Preferences section of this document 
for information about creating personal links. 
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Enhanced User Interface 
For this release, many changes were made to improve the usability of Banner forms. All 
Banner forms and menus have been changed to be more streamlined, modern, and easier 
to use. 

Tabbed Forms Make Navigating From Block To Block Easier 
Some Banner forms now have a tabbed interface rather than the traditional Banner 
window appearance. Tabs are used to arrange information in a meaningful way, and 
allow you to navigate easily between groups, or blocks, of information. You can use the 

 (Next Block) and  (Previous Block) functions, click on the tab, or use  

and , to navigate through blocks. Tab titles reflect the contents of a particular 
window or grouping of information. The illustration below shows the tabs on the 
SPAIDEN form, for instance. 

 
Use any of the following to navigate within tabbed forms: 

•  +  moves forward and  +  +  moves backward 
through the tabs on a form. 

• The List Tab Pages key ( ) displays a list of other tabbed windows on the 

form. Use the mouse or  and  to select a different tab, and  to 
select that tab. For forms that have tabs within a tabbed window, navigation is 
based on the location of the cursor when List Tab Pages (F2) is selected. 

•  (Next Block) or  +  moves forward and  (Previous Block) or 

 +  moves backward through the tabs (the same as Banner 6). 

New Screen Resolution Makes More Data Visible 
Banner 6 ran in a screen resolution of 800x600. Banner 7 now runs in a screen 
resolution of 1024x768, allowing ample room to display user interface components and 
eliminate many scrolling or stacked canvases. If the new Banner screen does not fit 
inside your Windows screen, you may need to change your screen resolution. See the 
next section for instructions. 
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Change Screen Resolutions In Any Version Of Windows 
1. Right-click on a blank area of your desktop, and select Properties from the pop-

up list. 
2. On the Properties dialog box, click the Settings tab. 
3. In the Screen Resolution area, drag the slider to the right until it says 1024 by 

768 pixels. 

4. Click . 

 

New Toolbar Icons For Banner 7 
Toolbar icons have a different layout in Banner 7. Icon pictures have changed; some 
icons have been moved for better grouping; while others have been added or removed.  

 
• The Broadcast Message button becomes enabled when new system-wide 

message(s) are available. 
• The Fine-Grained Access Control Security button becomes enabled if there are 

any FGAC rules active for the user in the database. 
• The Graph Information and Show Keys buttons have been removed. 
• The Banner Bookshelf button has been removed. You must install Adobe Acrobat 

Reader 7 and create a shortcut to N:/Banner/V7/Doc/bkshlf7x.pdf.  See Banner 7 
Changes on the go/inb website for more details. 

Disabled Text Easier To Read 
Disabled text is now black (the same as regular text), making it easier to read. 
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Options Available With Right Mouse Click 
The right mouse button now provides added 
functionality in Banner 7.  Available options can now 
be accessed by right-clicking on a blank area of the 
form (not on a field).  This pop-up list contains 
Rollback, Save, Exit, Print, and Add to Personal Menu 
as well as any form-specific options, both within the 
form (moving to blocks) or opening up a new form (see 
illustration at right). 
Note:  You can add any form to your My Banner menu 

with a single click.  To see a newly-added menu 
item you must refresh the menu by clicking the 
Menu link on the Banner Main Menu.  

Smart Toolbar 
A new smart toolbar has been added. This toolbar does not re-draw each time a form is 
opened, making the transition from one form to another faster. 

Enhanced User Preferences 
Access the enhanced user options on the Main Menu as follows:  

• From the File menu, select Preferences. 
or 

• In the Go To field, type GUAUPRF and then press . 
New Alert Options 
New Alert Options (on the Display Options tab) enable you to customize how you are 
prompted by Banner for the following: 

• Prompt Before Exiting Banner—Check this box if you want Banner to verify 
that you want to quit the Banner session before exiting. Unchecking the box will 
allow you to exit without being asked for confirmation. 

• Display Additional Confidential Alert—Check this box if you want Banner to 
display an extra Confidential message for records that contain confidential 
information. 

• Display Additional Deceased Alert—Check this box if you want Banner to 
display an extra Deceased message for records associated with a deceased person. 
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User-Defined Window Colors 
You can use the User Interface Color Settings (on the Display Options tab) to 
customize the color of the following items: 

• Buttons, such as  and  (buttons in the toolbar are not 
included) 

• Canvas (background space) of all forms 
• Record highlighting 
• Scroll and separator bars 
• Code/Description prompts 
• Canvases within the Main Menu, including the broadcast message, menu, and 

menu tree canvases 
To change the color of an item at the user level: 

1. From the File menu, select Preferences. Make sure the Display Options tab is 
selected. Make your changes on the User Interface Color Settings section on the 
right. 

2. For the item you want to change, click the  in the User Value field.  The 
Select color dialog box opens.  

• On the Swatches tab, you can choose a pre-defined color. 
• On the HSB tab, you can create your own shade by using HSB values (Hue 

Saturation Brightness). 
• On the RGB tab, you can create your own shade using RGB values (Red 

Green Blue). 

3. Click . 

4. Click  (Save) or press  to save your changes. 
Note:  Please be cautious about changing canvas or text colors. The text color and 

canvas color can NOT be the same. If they are, you will no longer be able to read 
the text! 
We recommend you work with the default color settings for a short while to get 
used to the new displays before you begin making changes. 
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Ability To Add Personal Links To The Banner Main Menu 
You can now add personal links to the Banner Main Menu. You can add links to web 
sites or Banner forms. 
To add or change Personal Links: 

1. From the File menu, select Preferences.   
2. Click the My Links tab. 
3. Enter a name for the link you want to change in the User Value field. 
4. Enter the URL (actual web address) or form name for the link you want to change 

in the next User Value field. 

5. Click  (Save) or press  to save your changes. 
Note:  You can create up to six personal links.  Each personal link has two records—the 

description and the URL/object.  Make sure you do not have pop-ups blocked 
with third-party software.  Google’s pop-up blocker may be bypassed by holding 

down  and then clicking your personal link.   

Blue Item Labels Replaced With Banner 7 Search Icon  
Formerly, blue field names indicated that the field had an LOV.  Now, both LOV fields 
and fields that are searchable have the Banner 7 Search icon next to them.  You can still 
have the blue field name appear if you would like.  You can change the color of 
Code/Description Prompt fields in the User Interface Color Settings section of the 
Display tab on the Preferences dialog box.  Change the Enter the RGB color for 
code/description prompts setting.  See the section on User-Defined Window Colors for 
instructions. 

Banner 7 Uses The Verdana Font 
Banner 7 uses the Verdana font for all text. 

Equal Left And Right Margins 
Banner 7 forms now have equal left and right margins. Banner 6 forms were off-center. 
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Calendar Icon Added To Data Entry Date Fields 

A new calendar icon ( ) has been added to date fields.  Formerly, you could double-
click inside the date field (which you can still do) but now it is more obvious that you 
can select a date from a calendar to populate the Date field.    

•  and  move to the 
calendar one year back or 
forward.   

•  and  move to the 
calendar one month back or 
forward.  

• Simply select the desired date 
from the calendar and then 

click . 
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New Banner Online Help 
Release 7.0 features a new online help system with information about forms and fields, 
and the tasks you can perform with Banner.  Help runs in a second web browser, 
therefore pop-up blockers will the use of the Help option.   
There are three ways to access it: 

• Click  on the toolbar. 
• From the Help menu, select Online Help.  
• Click the Help Center link on the Main Menu. 

Note:  For forms with no help, the Banner online help error page may not appear for 
Internet Explorer users who use IE’s “friendly” error messages by default.  
For optimal performance in IE do the following: 

1. In Internet Explorer, select Internet Options from the Tools menu. 
2. Click the Advanced tab. 
3. Clear the checkbox for the Show friendly HTTP error messages option. 

4. Click . 

Accessing Online Help From A Form 

 (Online Help) and the Help menu option initially display information about the 
form on which you are working. 

Accessing The Help Center 
If you want information about forms and tasks for another Banner product, use the Help 
Center link on the Main Menu of Banner, or from anywhere within the help system. 
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Features Of Online Help 
You can browse, search, and use the index to locate topics in online help. 

• Browsing for topics - The Contents tab and the bread crumb trail enable you to 
browse for topics. Form and field information is organized by Banner module. 
Task information is contained under the Procedures heading. 

• Searching for topics - The Search tab allows you to search for topics within the 
help system. You can also use your browser’s search feature to find specific text 
on a help page (from the Edit menu, select Find on this page.) 

• Using the index - The Index tab provides an alphabetical listing of topics within 
the help system. When you enter the letters of a topic, the index scrolls through 
the topics to the closest alphabetical match. 

 


