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Optimal Configurations To Run INB 
1. Start Internet Explorer (or your favorite browser). 

2. You can navigate to Internet Native Banner by one of two methods: 

• Type the address into your browser: 

a. In the Address field of your browser, type go/inb.  

b. Press  or . 

• Follow links from the Middlebury College home page: 

a. On the Middlebury College home page, click Library & 
Information Services at the bottom of the page. 

b. On the Library and Information Services page, click Banner, INB, 
Hyperion, FAMIS under the Quick Links heading. 

c. Click Internet Native Banner – INB. 

3. The gateway page to INB opens.  Create a Favorite for this page by doing the 
following: 

a. From the Favorites menu, select Add to Favorites.  The Add Favorite 
dialog box opens. 

b. Navigate to where you want to store this link. 

c. Click . 

4. Click on the link for the database you want to use.  Production is the most 
common choice as it contains our live data. 
Note:  If you have a pop-up blocker installed on your computer, you should 
disable it for this site before clicking the link to the desired database.  To do this: 

a. In IE, on the Tools menu, point to Pop-up Blocker, and then click Pop-up 
Blocker Settings on the submenu.  The Pop-up Blocker Settings dialog 
box opens. 
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b. In the Address of Web site to allow field, type jade.middlebury.edu. 

c. Click . 

d. Click . 

5. If you have never run INB before, you must install Oracle JInitiator now.  The 
procedure is:  

a. A Security Warning window opens which asks if you want to install 
Oracle JInitiator.  Click . 

b. The installation process begins and some progress windows display.   
Note:  If you have Spybot installed on your computer a Spybot – Search & 

Destroy window displays.  Click . 

c. When the Choose Location dialog box opens, click . 

d. When the installation completes, a pop-up window notifies you.  Click 
.  INB starts and presents the logon dialog box. 

6. If you get bumped out of Banner when you go to another web link, do this: 

a. Open a new Internet Explorer window. 

b. From the Tools menu, select Internet Options. 

c. Click the Advanced tab. 

d. Under Browsing, deselect the option that reads Reuse windows for 
launching shortcuts (the 17th option down). 

e. Click . 
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Logging Into INB After The First Time 
1. Start your browser. 

2. On the Favorites menu, click the Favorite for INB that you previously created. 

3. The gateway to INB page opens.  Click the link to the database that you want to 
use. 

4. In the Username field, type your username. 

5. In the Password field, type your password.  Leave the Database field blank. 

6. Click . 

          

• If your logon is correct, INB starts and the Banner General Menu 
(GUAGMNU form) displays. 

• If your login is incorrect, the error message ORA-1017:  invalid 
username/password; logon denied displays.   

Click  and you will be given another chance to login. 
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Change Screen Resolutions In Any Version Of Windows 
Banner 7 runs in a screen resolution of 1024x768, allowing ample room to display user 
interface components. If the Banner screen does not fit inside your Windows screen, 
you may need to change your screen resolution.  

1. Right-click on a blank area of your Desktop, and select Properties from the pop-
up list. 

2. On the Properties dialog box, click the Settings tab. 

3. Under Screen resolution, drag the slider to the right 
until it says 1024 by 768 pixels, as shown at right. 

4. Click .  

 

Your Internet Native Banner Session 
After you log into Internet Native Banner, there will be two buttons on your taskbar 
associated with your INB computing session: 

•  - The window associated with this button MUST REMAIN 
OPEN while you are running INB in a second window. 

•  - The window associated with this button is the one on which 
you will interact with INB.  It displays the Banner forms you request.  The 
database name appears in the title bar of any Banner form you open. 

Note:  On the General Menu (GUAGMNU form), the My Institution link allows you to 

open another Internet Explorer window.  You also see this link if you press  while 
in any Banner form. 
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Tool Bar Buttons And Key Stroke Shortcuts 
Tool Bar 
Button Function Key Stroke Shortcut 

 Save  

 Rollback  +  

 Select  +  

 Insert Record  

 Remove Record  +  

 Previous Record  

 Next Record  

 Previous Block  +  

 Next Block  +  

 Enter Query  

 Execute Query  

 Cancel Query  +  

 On-Line Help  

 Exit  +  

 Next Field  

 Previous Field  +  

 Next Tab  +  

 Previous Tab  +  +  
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Banner General Menu 
1 
 

2 
 

3 
 
 

4 
 
 

 
 
 
 

5 
 
 
 

6 
 

 

1. Banner Menu Bar with drop-down menus. 

2. Go To gives access to a form by entering the Banner form name or QuickFlow 

name.  While your cursor is in the Go To field, you can use  or  to scroll 
through recently used forms. 

3. Products drop-down gives you quick access to the Banner modules and 
associated menus.  Point at the , then press and hold the mouse button to see 
the module list.  Drag to your selection and then release the mouse button. 

4. Banner General Menu lets you navigate through the folder structure to 
submenus and forms. 

• To expand or collapse a menu, double-click  (Folder icon). 

• To open a form, double-click the form name in the menu which will be 

preceded by  (Form icon). 
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• To quickly return to a main menu, select the desired module from the 
Products drop-down. 

5. The Links frame displays the links described below: 

• Menu refreshes the General Menu, reflecting any changes made. 

• Site Map is a navigation aid.  Double-click anything on the lists to open 
the desired folders in the given module. 

• Help Center opens a separate browser window showing SCT Banner Help 
Center topics.  Click links to learn about Banner topics. 

• In the My Links section Banner provides you with 6 customizable links 
which you may configure to open web sites, forms, or Quickflows of your 
choosing. 

6. The Auto Help Line displays a status line with error messages or important 
information about your next step. 
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Navigating To Advancement Individual Summary Form 
(APASBIO) 
You can view basic name and address information about people using the Banner 
Advancement Individual Summary (APASBIO). 

1. Start your browser, and click your Favorite to the INB gateway page as described 
in previous sections. 

2. Select the database you want to use and login (again, as described in previous 
sections). 

3. When the general menu (GUAGMNU) appears, open the APASBIO form. 
• Go To method: 

a. Type APASBIO in the Go To field. 

b. Press ; the APASBIO form appears. 
• Menu Navigation method – double-click the following items to open 

them: 
a. Banner 
b. Advancement 
c. Advancement Individual 
d. Advancement Individual Query 
e. Advancement Individual Summary [APASBIO] 

The key block of the APASBIO form displays. 

Go To 
method, type 
form name in 
the Go To 
field then 
press 

. 
 

Menu 
Navigation 
method, open 
menus and 
double-click 
Advancement 
Individual 
Summary 
APASBIO. 
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Parts Of Banner Forms 
 
A 
B 
C 
D 
E 
F 
 
G 
 
H 
 
I 
 
J 
 
 
 
K 

A.  Menu Bar – Displays the pull-down menus available to you.  The Options 
menu is important to you.  It allows you to go to other blocks of the current 
form or open other useful, related forms.  Pay attention to where you are and 
remember that all forms remain open until you close them. 

B.  Toolbar – Toolbar buttons are briefly explained in the Toolbar Buttons And 
Key Stroke Shortcuts section. 

C.  Form Title Bar – Displays the form description, the Banner form name, the 
Banner release number, and the database you are using. 

D.  Key Block Area – The first block of a form.  Contains identification 
information related to the form’s function.  It allows you to search for the 

unique identifier of the record you want to view.  Click  (Next Block) or 

press  +  to move to the next block.  A form may have several 

blocks.  Click  (Next Block) or press  +  until no more 
blocks are presented. 
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E.  Tabs – Some Banner forms have a tabbed interface with titles that reflect the 

contents of a particular window or grouping of information.  Tabs are used to 
arrange information in a meaningful way, and allow you to navigate easily 
between blocks of information.  Navigation with tabs is done in several ways: 

• Click on the tab to move to another block in the current form. 

• Use  + , or   +  + to navigate through 
information grouped on tabs. 

•  calls up a list of all available tabs. 
F.  Iconic Buttons – These buttons are small squares that contain an icon 

(picture).  They represent one or more actions that can be performed for the 
associated field or record, such as searching for a person or displaying 
additional details.  Point to a button with your mouse; a tool tip will give a 
brief description of its function. 

•  - The Search button displays another form or window where you 
can search for a value or information related to the field.  You can often 
select a value by double-clicking it, returning it to the associated field.  

G.  Block Line – Indicates the block boundaries. 
H.  Active Field – Denoted by a blinking cursor, highlighted field or a field and 

label outlined with dots to draw your attention to it.  Note the example on the 
previous page shows the dotted outline above and below the male gender radio 
button and label.  You may find this easier to see on your screen. 

I.  Field Label – The Field Label is usually adjacent to the Field and is 
descriptive of the Field contents.  Some Field Labels appear above a column. 

J.  Field – Fields contain data and display existing data values.  Users can enter, 
query or change field contents when a field is enabled.   

K.  The Auto Help Line – Status line at the bottom of every Banner screen that 
displays error messages or important information about your next step. 

Remember your best Banner friend, the 

Auto Help Line! 
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Navigating Forms 
There are a variety of navigation methods in Banner.  Brief descriptions of these 
methods follow. 

1. Toolbar Buttons 

•  (Next Block) moves to the next informational block on your form. 

•  (Previous Block) moves to the previous informational block on your 
form. 

•  (Rollback) returns to the Key Block of the current form. 

•  (Exit) exits the current form. 

2. Keyboard Shortcuts 

•  +  moves to the next block on your form (like ). 

•  +  moves to the previous block on your form (like ). 

•  moves your cursor to the next field. 

•  calls up the Go To field and allows you to type in a form name.  It 
also provides a link to the Middlebury site that opens in its own window. 

•  calls up a list of the tabs on the current form. 

3. Tabs 

• Click tabs to move to other groups of information on the current form.  
Each tab may have more than one block within the screen. 
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4. Menus 

• File menu – provides quick access to recently used forms that appear in a 
numbered list at the bottom of the menu.  You can also select Return to 
Menu on the File menu which closes all open forms and returns to the 
General Menu GUAGMNU or choose Exit Banner from the File menu 
to close all forms and end your Banner session. 

• Options menu – allows access to various blocks of the current form, and 
access to other related forms. 

5. Mouse 

• Right-click a blank area on your form.  The pop-up list gives access to 
blocks of current forms and to related forms. 

 

Using Advancement Individual Summary Form 
APASBIO 
You can use the form Advancement Individual Summary APASBIO to: 

• View name, address, and telephone information for Middlebury-affiliated people 
(constituents) including students, faculty, staff, and alums. 

• Perform person searches that look only in the constituent group (instead of 
including vendors and inquirers). 

• View or search by alternate names, such as maiden names and nicknames. 

 

Viewing Constituent Information 
1. Open the APASBIO form using the instructions in the section Navigating To 

Advancement Individual  Summary Form (APASBIO).  APASBIO opens with 
your cursor in the ID field. 
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2. Search for the person in one of three ways: 
 

Method A, used when you know the ID number of the person: 

a. In the ID field, enter the eight-digit ID number of the person. 

b. Press  or .  If the ID number is valid, the APASBIO Key 
Block is populated with information.  

 

Method B, used when you do not know the ID number of the person: 

a. Leave the ID field blank, or delete any existing ID number.  Press ; 
your cursor moves to the blank name field. 

b. In the name field (the large, unlabeled field to the right of the ID field), 
type all or part of the person’s last name, followed by a comma, then at 
least a portion of the first name.  Use the % wildcard to complete any 
partial name entries.  You may use more than one % wildcard. 
Note:  Searches using this field are not case sensitive (you may use slater, 
c% to search for Slater, Cynthia.) 

c. Press  or . 

• If the last name is unique, the APASBIO Key Block is populated 
with information. 

• If the name is not unique, the ID and Name Extended Search 
APASBIO form opens.  The number of names found is displayed to 
the right of the Search Results drop-down list.  There are two 
methods of reviewing the information found: 

o Click  next to Person Search Detail.  The Advancement 
Individual Search AOAIDEN form opens.  You can review 
gender, class, and address information to insure the correct 
selection.  Double-click on the desired name to bring the 
person’s information back to APASBIO. 
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o Click  or press  +  to see the name and ID 
information in the Search Results drop-down list.  Click on 
the desired name to bring the person’s information back to 
APASBIO.  Review the category and class information 
displayed in the Key block to be sure you have the correct 
person. 

 

Method C, alternate method if the ID number is unknown: 

a. Click  after the ID field.  The Option List window appears. 

b. Click on Constituent Search (AOAIDEN).  The form opens in query 
mode. 

c. In the Last Name field, type the last name of the person. 

d. If the surname is a common one, in the First Name field, type at least part 
of the first name followed by a %. 

e. Click  (Execute Query) or press .  AOAIDEN is populated with 
all matches. 

f. Double-click anywhere on the record of the person for whom you want to 
view information.  You are returned to APASBIO and the Key Block is 
populated with information on the chosen person. 

3. View more information about the constituent. 

• Click  (Next Block) or press  +  to see additional 
blocks of information. 

• Click a tab to move to related groups of information. 

• From the Options menu on the menu bar, select the name of the block or 
form desired. 

• Right-click on a blank area of the form for a pop-up list of blocks. 
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Developing Your Own Personal Banner Menu Using The 
GUAPMNU Form 

1. Open the GUAPMNU form as follows: 

• In the Go To field, type GUAPMNU and press .   

Or 

• From the My Banner menu, double-click Organize My Banner 
[GUAPMNU]. 

My Banner Maintenance GUAPMNU opens (see the illustration on the next 
page). 

2. Use one of two methods to add items to your personal menu: 

• Supply the name as follows: 

a. Click in the right-side frame, in the Object column, just below the 
last item on your menu. 
Tip:  To position a menu item in the list, click once on the item 
name or description above the desired location, then click  (Insert 
Record).  A new row will appear. 

b. Type the name of the form you want to add; form names are always 
seven characters, such as APASBIO. 

c. Press . 

d. Press  to add another form. 

• Item selection from the pane on the left: 

a. First, click once on the Object name or Description to determine the 
position of your new item in the pane on the right.  The new item 
will be added below your selection. 
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b. Use the pull-down menu above the left pane to select the object type 
to display from the choices:  Dynamically Linked Library, Job 
Submission object, Menu Message object, Menu object, Oracle 
Forms module, QuickFlow object. 

c. Click  to sort objects, if desired. 

d. In the left frame, double-click each item you want to add to your 
personal menu. 

e. Move the selected items to the right pane by clicking . 

3. You can remove any unwanted entries by double-clicking the item in the 

right-hand pane, turning it blue, then clicking . 

4. When you are finished, click  (Save) or press . 

5. Click  (Exit) to return to the Banner menu. 

6. Click the Menu link (top-right) to refresh the My Banner menu, reflecting your 
changes. 
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Developing Your Own Personal Banner Menu Using The 
Pop-up Menu 

1. Right-click on a blank area of any form. 

2. Select Add to Personal Menu on the pop-up menu. 

3. Click Menu on the General Menu page to refresh the menu, including your 
added form. 

 

 
A Personal Menu 

 

Using The My Banner Menu 
1. Double-click My Banner in the General Menu to open your personal menu. 

2. Double-click any form in the menu to open it. 

Tip:  You can change your settings to specify that your My Banner menu is 
already open when you log on.  See the next section for details. 
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Setting User Preferences 
Access the user options on the General Menu as follows:  

• From the File menu, select Preferences. 

or 

• In the Go To field, type GUAUPRF and then press . 

Start Menu Options 
You can change how Banner acts on start up. 

1. Click the Menu Settings tab. 

2. Change the User Default value to *Personal, the press .  My Banner will 
be filled in. 
Note:  You must log out and log in again before this setting takes effect. 

Alert Options 
Alert Options (on the Display Options tab) enable you to customize how you are 
prompted by Banner for the following: 

• Prompt Before Exiting Banner—Check this box if you want Banner to verify 
that you want to quit the Banner session before exiting. Unchecking the box 
allows you to exit without confirmation. 

• Display Additional Confidential Alert—Check this box if you want an extra 
Confidential message displayed for records that contain confidential information. 

• Display Additional Deceased Alert—Check this box if you want a Deceased 
message to display for records associated with a deceased person. 
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User-Defined Window Colors 
You can use the User Interface Color Settings (on the Display Options tab) to 
customize the color of buttons, such as  and  (buttons in the toolbar 
are not included), canvas (background space) of all forms, record highlighting, scroll 
and separator bars, Code/Description prompts, canvases within the General = Menu, 
including the broadcast message, menu, and menu tree canvases. 

To change the color of an item at the user level: 

1. From the File menu, select Preferences. Make sure the Display Options tab is 
selected. Make your changes on the User Interface Color Settings section on the 
right. 

2. For the item you want to change, click the  in the User Value field.  The 
Select color dialog box opens.  

• On the Swatches tab, you can choose a pre-defined color. 

• On the HSB tab, you can create your own shade by using HSB values (Hue 
Saturation Brightness). 

• On the RGB tab, you can create your own shade using RGB values (Red 
Green Blue). 

3. Click . 

4. Click  (Save) or press  to save your changes. 

Note:  Please be cautious about changing canvas or text colors. The text color and 
canvas color can NOT be the same. If they are, you will no longer be able to read 
the text! 

We recommend you work with the default color settings for a short while to get 
used to the displays before you begin making changes. 
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Adding Personal Links To The Banner General Menu 
You can add up to 6 personal links to web sites or Banner forms on the Banner General 
Menu.  

To add or change Personal Links: 

1. From the File menu, select Preferences.   

2. Click the My Links tab. 

3. Enter a name for the link you want to change in the User Value field. 

4. Enter the URL (actual web address) or form name for the link you want to change 
in the next User Value field.  See the illustration on the next page.  Note that 
your configuration of a personal link requires two sets of Description, Default 
Value, and User Value fields. 

5. Click  (Save) or press  to save your changes. 

 

Note the two sets of 
Description, Default 
Value, and User Value 
fields.  

 
Note:  Make sure you do not have pop-ups blocked with third-party software while 

adding Personal links. 


